Final Configurations

All passwords are: juniper123

Config file downloads:

You'll note that the final configs for J2300-3 and J2300-4 are missing. This is left as an exercise to the student (code: I accidentally deleted them)

Here is the final config for J2300-1

system {
    host-name J2300-1;
    root-authentication {
        encrypted-password "$1$KUi/iDD6$MCL5jDu1YOY34UJnY1Umx1"; ## SECRET-DATA
    }
    login {
        user admin {
            uid 2000;
            class super-user;
            authentication {
                encrypted-password "$1$2WNXM.8b$5xkkkgaya5VgOlTrJNG9E0"; ## SECRET-DATA
            }
        }
    services {
        ssh {
            root-login allow;
            protocol-version v2;
        }
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    fe-0/0/0 {
        unit 0 {
            family inet {
                address 10.99.1.2/24;
                address 172.16.11.11/24;
            }
        }
    }
    fe-0/0/1 {
        vlan-tagging;
        unit 12 {
            bandwidth 10g;
            vlan-id 12;
            family inet {
                address 10.0.12.1/24;
            }
            family mpls;
        }
        unit 13 {
            vlan-id 13;
            family inet {
                address 10.0.13.1/24;
            }
            family mpls;
        }
        unit 100 {
            vlan-id 100;
            family inet {
                address 10.30.30.1/17;
            }
        }
        unit 101 {
            vlan-id 101;
            family inet {
                address 10.101.0.1/24;
            }
        }
        unit 102 {
            vlan-id 102;
            family inet {
                address 10.102.0.1/24;
            }
        }
        unit 1001 {
            vlan-id 1001;
            family inet {
                address 10.1.111.1/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.0.0.1/32;
            }
        }
    }
}
routing-options {
    graceful-restart;
    static {
        route 5.1.1.0/25 receive;
        route 5.2.1.0/25 receive;
    }
    forwarding-table {
        export LOAD-BALANCE;
    }
}
protocols {
    rsvp {
        interface fe-0/0/1.13;
        interface fe-0/0/1.12;
    }
    mpls {
        icmp-tunneling;
        label-switched-path R1-R6 {
            to 10.0.0.6;
        }
        interface fe-0/0/1.12;
        interface fe-0/0/1.13;
    }
    ospf {
        traceoptions {
            file ospf.log;
            flag graceful-restart detail;
        }
        graceful-restart {
            restart-duration 150;
            helper-disable;
        }
        traffic-engineering;
        external-preference 171;
        export [ LOOPBACK ADVERTISE-STATIC ];
        import IGNORE;
        reference-bandwidth 25g;
        area 0.0.0.0 {
            area-range 10.101.0.0/16;
            virtual-link neighbor-id 13.13.13.13 transit-area 101.101.101.101;
            interface fe-0/0/1.12 {
                interface-type p2p;
                metric 5;
                te-metric 10000;
                retransmit-interval 8;
                authentication {
                    simple-password "$9$RsaSKWN-b2ga69eM8XdV"; ## SECRET-DATA
                }
                bfd-liveness-detection {
                    version 1;
                    minimum-interval 1000;
                }
                neighbor 10.0.12.2;
            }
            interface fe-0/0/1.13 {
                interface-type p2p;
                link-protection;
                metric 5;
                te-metric 10000;
                retransmit-interval 8;
                authentication {
                    md5 7 key "$9$ZPjqPQF6/AuEc7VbsJZ9AtOIheKWLNV"; ## SECRET-DATA
                }
                flood-reduction;
                bfd-liveness-detection {
                    minimum-interval 1000;
                }
            }
            interface lo0.0 {
                passive;
            }
            label-switched-path R1-R6 {
                disable;
                metric 1;
            }
        }
        area 101.101.101.101 {
            interface fe-0/0/1.101 {
                authentication {
                    simple-password "$9$YmoUHf5FCA0k.0IESMWGDi"; ## SECRET-DATA
                }
            }
        }
        area 102.102.102.102 {
            area-range 10.102.0.0/24 restrict;
            interface fe-0/0/1.102 {
                authentication {
                    md5 88 key "$9$ZbUiqmPQ/CuX72aZU.m3n/AORrlM8LNreLNbwJZ/Ct"; ## SECRET-DATA
                }
            }
        }
        area 0.0.0.1 {
            nssa {
                default-lsa {
                    default-metric 1000;
                    metric-type 1;
                    type-7;
                }
                no-summaries;
                area-range 3.0.0.0/8;
                area-range 4.0.0.0/8;
            }
            area-range 10.1.0.0/16 override-metric 5000;
            interface fe-0/0/1.1001 {
                priority 0;
                retransmit-interval 3;
                hello-interval 1;
                dead-interval 11;
            }
            interface fe-0/0/1.13 {
                secondary;
            }
        }
        area 30.30.30.30 {
            interface fe-0/0/1.100 {
                priority 255;
            }
        }
    }
}
policy-options {
    policy-statement ADVERTISE-STATIC {
        term 5.1.1-NET {
            from {
                protocol static;
                route-filter 5.1.1.0/25 exact;
            }
            then {
                metric 1;
                tag 1;
                external {
                    type 1;
                }
                accept;
            }
        }
        term 5.2.1-NET {
            from {
                protocol static;
                route-filter 5.2.1.0/25 exact;
            }
            then {
                metric 2;
                tag 2;
                accept;
            }
        }
    }
    policy-statement FAVORITE-NETWORK {
        from {
            protocol static;
            route-filter 11.11.11.0/24 orlonger;
        }
        then {
            metric 11;
            accept;
        }
    }
    policy-statement IGNORE {
        from {
            route-filter 5.1.0.0/16 orlonger;
            route-filter 5.2.0.0/16 orlonger;
        }
        then reject;
    }
    policy-statement LOAD-BALANCE {
        then {
            load-balance per-packet;
        }
    }
    policy-statement LOOPBACK {
        from interface lo0.0;
        then accept;
    }
    policy-statement TEST {
        then {
            metric 10000;
            external {
                type 1;
            }
        }
    }
}